Тема: Циклічні алгоритми




Скачати 45.16 Kb.
НазваТема: Циклічні алгоритми
Дата конвертації18.04.2013
Розмір45.16 Kb.
ТипДокументы
uchni.com.ua > Інформатика > Документы
Лабораторна робота № 3

Тема: Циклічні алгоритми.

Мета: навчитися складати схеми циклічних алгоритмів.

Обладнання: інструкція до практичної роботи, олівець лінійка.
Хід роботи.

  1. Правила Т/Б в кабінеті комп'ютерної техніки.

  2. Методичні вказівки.

Базова структура „цикл". Забезпечує багаторазове виконання деякої сукупності дій, яка називається тілом циклу. Основні різновиди циклів приведені в таблиці:

алгоритмічна мова


мова блок-схем


Цикл типу ПОКА.

Наказує виконувати тіло циклу до тих пір, поки виконується умова, записана після слова пока


нц пока условие

тело цикла (последовательность действий )





Цикл типу ДЛЯ.

Наказує виконувати тіло циклу для всіх значень деякої змінної (параметра циклу) в заданому

діапазоні


нц для і от і 1 до І2

тело цикла

(последовательность действий)

кц





Примеры структури ЦИКЛ

Алгоритмічний язик

Мова блок-схем

нц пока і<=5

S:=S+A[i]

i:=i+1

кц





нц для і от 1 до 5

Х[і]:=i*і*і

Y[i]:=X[i]/2

кц





3. Скласти алгоритм ітераційного циклу.

Скласти алгоритм обчислення нескінченної суми з

заданою точністю є (для даної нескінченої суми, що знакочергується, потрібна точність буде досягнута, коли черговий доданок буде за абсолютною величиною менше є).

Обчислення сум - типова циклічна задача. Особливістю ж нашої конкретної задачі є те,

що число доданків заздалегідь невідомо. Тому виконання циклу повинне завершитися в

момент потрібної точності.

При складанні алгоритму потрібно врахувати, що знаки доданків чергуються і ступінь

числах в чисельниках доданків зростає.

Розв'язуючи задачу „в лоб" шляхом обчислення на кожному i-му кроці часткової суми

S := S + ((-1)**(/-1))*(х**/)//, ми отримаємо дуже неефективний алгоритм, що

потребує виконання великого числа операцій. Набагато краще організувати обчислення

наступним чином: якщо позначити чисельник якого-небудь доданку буквою р, то у

наступного доданку чисельник буде дорівнювати -/?*х (знак мінус забезпечує чергування

знаків доданків), а сам доданок т буде дорівнювати р/і, де i - номер доданку.

алгоритмічна мова

блок схема


алг Сумма (арг вещ х, Eps, рез вещ S)

дано [ 0<х<1

надо | S=x-x**2/2+x**3/3-...

нач цел і, вещ m, p

ввод х, Eps

S:=0; i:=l | Начальные значення

m:=1; р:= -1

нц пока abs(m)>Eps

р:= -р*х | р - числитель очередного слагаемого

m:= р/і | m - очередное слагаемое

S:-S+m | S - частична сумма

і:= і+1 | і - номер очередного слагаемого

кц

вывод S

кон





Алгоритм у склад якого входить ітераційний цикл, називається ітераційним алгоритмом. Ітераційні алгоритми застосовують при реалізації ітераційних чисельних методів.

4. Індивідуальне завдання. Скласти схему алгоритму. Варіанти.

  1. Знайдіть значення виразу (для натуральних-m і п, т<п): S=l+2+...+n

  2. Знайдіть значення виразу (для натуральних т і п, т<п): F= 1 *2*...*п

  3. Знайдіть значення виразу (для натуральних т і п, т<п): A=m+(m+l)+...+(m+n)

  4. Знайдіть значення виразу (для натуральних т і п, т<п): B=m*(m+l)*...*(m+n)

5. Знайдіть значення виразу (для натуральних т і п, т<п):

6. Знайдіть значення виразу (для натуральних m i n, m<=n):

S=1+1*2+1*2*3+1*2*3*4+…+1*2*3*…n

7. Знайдіть значення виразу (для натуральних т і п, т<п):

8. Знайдіть суму S і добуток Р парних чисел від 1 до п.

9. Знайдіть суму S і добуток Р непарних чисел від 1 до п.

10. Знайдіть суму S і добуток Р чисел кратних 3, від 1 до п.

11. Знайдіть суму квадратів перших п натуральних чисел.

12. Знайдіть суму кубів перших п натуральних чисел.

13. Знайдіть суму квадратів парних чисел з перших п натуральних чисел.

14. Знайдіть суму кубів парних чисел з перших п натуральних чисел.

15. Для послідовності a(n)=nsinn знайдіть суму і добуток п перших членів.
5. Контрольні питання

  1. Накреслити схему простого циклу.

  2. Що таке тіло циклу?

  3. Для чого потрібна змінна циклу.

6. Захист роботи.

Схожі:

Тема: Циклічні алгоритми iconУрок №12 -13 Тема: циклічні алгоритми. Види та запис циклів на мові Паскаль
...
Тема: Циклічні алгоритми iconТема: „Циклічні переходи. Цикл з передумовою For”. Мета
Мета: Навчальна: Дати дітям початкове уявлення що таке цикли, для чого вони потрібні
Тема: Циклічні алгоритми iconТема уроку: Причини економічних коливань. Економічні піднесення та...

Тема: Циклічні алгоритми iconУрок №2 Інформатика Дата 14. 10. 11 Тема. Виконавець та система команд...
Мета уроку. Навчити учнів класифікувати алгоритми за їх структурою, ознайомити з базовими структурами алгоритмів
Тема: Циклічні алгоритми iconТема: Загальна блок-схема
Алгоритми можна представляти як деякі структури, що складаються з окремих базових
Тема: Циклічні алгоритми iconТема уроку: Алгоритми. Властивості алгоритмів. Форми подання алгоритмів....
Тема уроку: Алгоритми. Властивості алгоритмів. Форми подання алгоритмів. Виконавець алгоритму
Тема: Циклічні алгоритми iconТема: Розробка програм з циклічними обчислювальними процесами
Ціль роботи: Вивчити написання програм мовою С, використовуючи ітераційні (циклічні) методи, освоїти основні оператори, що підтримують...
Тема: Циклічні алгоритми iconУрок № Тема. Практична робота №6 „Розроблення та реалізація найпростіших...
Використовують в програмуванні три форми циклів: цикл з параметром, цикл з передумовою, цикл з післяумовою
Тема: Циклічні алгоритми iconУрок з інформатики 11 клас Тема «Алгоритми. Властивості алгоритмів. Побудова алгоритмів.»
...
Тема: Циклічні алгоритми iconТема. Мінімуми І максимуми
Однопрохідні алгоритми мають одну важливу перевагу: для них не треба зберігати в пам’яті одночасно весь набір даних, тому в програмній...
Додайте кнопку на своєму сайті:
Школьные материалы


База даних захищена авторським правом © 2014
звернутися до адміністрації
uchni.com.ua
Головна сторінка